Для поиска темы - пользуйтесь СИСТЕМОЙ ПОИСКА


Стоимость дипломной работы


Home Для студента... Синтаксис языка 1С

Синтаксис языка 1С
загрузка...
Рейтинг пользователей: / 0
ХудшийЛучший 

Лекция 11

Тема: Синтаксис языка 1С

1. Конфигуратор
Все начинается с запуска Конфигуратора. Программы для 1С:Предприятие называются "конфигурациями" и создаются они в специальном режиме для разработчика "Конфигуратор". Обычные пользователи работают в режиме "Предприятие".

Объекты, атрибуты и методы
Самое главное понятие 1С -- это "объект". Объект - это элемент реального мира. Но нас интересуют только те объекты, которые имеются в офисной деятельности предприятия: документы, отчеты, справочники... Программа для 1С представляется как совокупность объектов, взаимосвязанных между собой, т.е. конфигурация объектов. Например, документ "Приказ о приеме на работу", справочник "Сотрудники", отчет "Сотрудники, принятые за период".
У объектов имеются некоторые атрибуты (свойства, реквизиты). Например, сотрудник имеет фамилию, имя, отчество, оклад, табельный номер. Приказ о приеме имеет номер и дату. Набор свойств объекта задается разработчиком.
Также объекты имеют определенные методы (процедуры и функции). Например, вы можете выбрать всех сотрудников с помощью метода справочника ВыбратьЭлементы(), или можно сохранить документ методом Записать().

Встроенный язык
Поведение объектов конфигурации задается на встроенном языке. Программист может писать на встроенном языке 1С свои собственные модули, состоящие из процедур и функций. Встроенный язык позволяет работать со справочниками, документами и другими объектами 1С. Можно, например, с помощью методов объектов выбрать все элементы справочника Сотрудники для вывода в отчет, или создать и сохранить любой документ.

Модули, процедуры и функции
Вся конфигурация, как вы уже наверное заметили, состоит из модулей. Это могут быть модули документов или модули отчетов или другие модули. Модули состоят из процедур и функций. Процедура -- это небольшая программа для выполнения определенной задачи. Функция отличается от процедуры, только тем, что имеет результат. Говорят, "функция возвращает результат". Например, модуль "Приказа о приеме на работу" может иметь следующие процедуры ПроверитьПравильность( ) и НапечататьПриказ( ).

Глобальный модуль
В системе 1С есть так называемый Глобальный модуль.Он относится к конфигурации в целом. Глобальный модуль нужен для того, что писать процедуры и функции, доступные в любом месте программы (в любом другом модуле). Для этого необходимо просто указать ключевое слово Экспорт. Также можно создать глобальные переменные, которыми можно будет пользоваться в любом месте программы. Но чем меньше будет таких глобальных переменных, тем лучше, так как модули получаются более независимыми друг от друга, что снижает количество ошибок в программе и облегчает отладку.

 

 


2. Конструкции языка 1С
Язык 1С очень похож на Бейсик. В 1С все ключевые слова можно писать по-русски.
Конструкция языка 1С Примечание
Процедура РассчитатьНалог(Сотрудник, НекаяДата)
КонецПроцедуры Простая процедура. После слова КонецПроцедуры точка с запятой не нужна, потому что это не оператор, а операторная скобка
Функция РассчитатьНалог(Сотрудник, НекаяДата)
Возврат Налог;
КонецФункции Функция должна обязательно возвращать результат.
Если Оклад > 10000 Тогда
......Результат = "Нормально";
Иначе
......Результат = "Плохо";
КонецЕсли; Простое условие. После слова КонецЕсли должна быть точка с запятой, потому что так заканчивается оператор Если
Результат = ?(Оклад > 10000, "Нормально","Плохо"); Сокращенное Если.
Если Оклад > 10000 Тогда
......Результат = "Нормально";

ИначеЕсли Оклад > 5000 Тогда
......Результат = "Средне";

Иначе
......Результат = "Плохо";
КонецЕсли; Множественное условие. Если первое условие не выполняется, то проверяется второе. Если второе условие не выполняется, то третье. Если ни одно из условий не выполняется то выполняется блок Иначе.
Если (Оклад > 10000) И (КодКатегории = 2) Тогда
КонецЕсли; В составном логическом выражении скобки обязательны!
Пока Номер <= 50 Цикл
КонецЦикла; Простой цикл Пока (цикл с неизвестным числом повторений). После слова КонецЦикла должна быть точка с запятой, потому что так заканчивается оператор Пока
Для Номер = 1 По 50 Цикл
КонецЦикла; Простой цикл Для (цикл с известным числом повторений).
Перейти ~метка;
<...>
~метка:  Так оформляются метки и оператор безусловного перехода (GOTO). Чем меньше в вашей программе будет меток, тем лучше.
Пока <условие> Цикл
Если <условие> Тогда
........Продолжить;
КонецЕсли;
КонецЦикла; Оператор Продолжить передает управление в начало цикла.
Пока <условие> Цикл
Если <условие> Тогда
.........Прервать;
КонецЕсли;
КонецЦикла; Оператор Прервать производит досрочный выход из цикла. Управление передается на операторы после цикла.
Перем Сотр; Явное объявление переменной.
Номер = 1; Переменные можно не объявлять явно. При первом присвоении значения создается новая переменная.
ФИО = Фамилия + " " + Имя + " " + Отчество; Сложение строк (конкатенация)
НекаяДата = '01.01.2002'; Переменная, которая хранит дату.
Перем глТекущийПользователь Экспорт; Объявление глобальной переменной в Глобальном модуле. Такие переменные доступны в любом месте конфигурации.
Попытка
а = 10 / 0;
Исключение
Предупреждение("Деление на ноль!");
КонецПопытки; Обработка исключительных ситуаций.
Если во время выполнения операторов между словами Попытка и Исключение произошла ошибка, то управление передается на операторы между словами Исключение и КонецПопытки
Если ошибки не было, то управление передается на операторы после слова КонецПопытки.
//это комментарий Так оформляются комментарии.
СпрСотр.ВыбратьЭлементы(); Вызов метода объекта производится как обычно, через точку.


 
загрузка...

Добавить комментарий


Защитный код
Обновить